perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Apache 2.2.6, mod_perl 2.0.3 msvcrt.dll start problem
Date Sun, 10 Feb 2008 13:44:19 GMT
Hi guys,
thank you very much for all the interest in the issue, but
could one of you summarise and tell me what I should do ?  Should I
- go back to ActivePerl 8.8.820 (instead of 8.8.22 currently) ?
- do something else (like what Jan Dubois said below ? (or is that just 
for the people creating the binary mod_perl package ?)
- use another combination altogether ?
(I cannot compile under Windows)

As per below, my immediate problem is solved, but it would be nice to 
have the "clean" solution for future reference.

Thanks,
André

P.S.
In the meantime, under Windows XP SP 2 German,  I did try the de-install 
of ActivePerl 8.2.822, re-install of ActivePerl 8.2.820, and re-install 
mod_perl using the "mpinstall" script, and everything works fine, 
including starting Apache (2.2.8) as a service   The error with 
msvcrt.dll does not appear anymore. I tried a dozen Apache service 
startup cycles and got no error.

The same procedure, same Perl 8.8.820 but with Apache 2.2.6 works fine 
too on another Windows XP SP2, Spanish workstation, which also had some 
problems with AP 8.8.822.




William A. Rowe, Jr. wrote:
> Jan Dubois wrote:
>>   
>> http://downloads.activestate.com/ActivePerl/Windows/5.8/ActivePerl-5.8.8.822-MSWin32-x86-280952-symbols.zip

>>
>>
>> The symbols.zip file should be unpacked in the C:\Perl directory, or
>> wherever you installed ActivePerl as it contains .pdb file for both the
>> bin and the lib subtree.  All symbols should then automatically fall
>> into the correct places.
> 
> Excellent, thanks Jan!!!
> 


Mime
View raw message