perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "B Wooster" <bwooste...@gmail.com>
Subject Re: [mp2] [question] $ENV{PATH} changes not taking effect?
Date Thu, 17 Jan 2008 18:05:10 GMT
Under modperl, get zero bytes output, HTTP response code is 200, though.

Apache error_log shows:
[Thu Jan 17 12:47:15 2008] -e: Can't exec "basename": No such file or
directory at /var/www/perl/script.pl line 12.

So, under modperl, changes to $ENV{PATH} are not accepted (like
perl-script), but the default value for that is probably empty (or
does not contain /bin).

I also tried adding PerlSetEnv in this case, but still same output -
no output, and same error as above, for this Apache config:
<Directory /var/www/perl>
    SetHandler modperl
    PerlSetEnv PATH /bin/:
    PerlResponseHandler ModPerl::Registry
    PerlOptions +ParseHeaders
    Options +ExecCGI
</Directory

perl-status shows:
Under the "modperl" handler, the environment is:
MOD_PERL = mod_perl/2.0.3
MOD_PERL_API_VERSION = 2
PATH = /sbin:/usr/sbin:/bin:/usr/bin

On Jan 17, 2008 9:00 AM, Jim Brandt <cbrandt@buffalo.edu> wrote:
> What happens if you try running it with the modperl handler instead of
> the perl-script handler?

Mime
View raw message