perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From (Andreas J. Koenig)
Subject Re: RELEASE CANDIDATE] mod_perl-1.31 RC1
Date Mon, 24 Dec 2007 07:39:28 GMT
>>>>> On Sun, 23 Dec 2007 14:35:51 -0800, "Philippe M. Chiasson" <>

  > Oh, are you trying to build mod_perl statically ?

Yes, I've always built it statically. I thought that is the default on linux.

 >>>>>>> On Fri, 21 Dec 2007 23:36:53 -0800, "Philippe M. Chiasson" <>

  > Yes, but I'd like to try reproducing this myself.

  > Can you tell me:

  > $> perl -V:config_args

config_args='-Dinstallusrbinperl=n -Uversiononly -Dusedevel -des -Dprefix=/usr/local/perl-5.10.0

The usedevel bit has no significance for stable/released perls, I just
have it always there.

  > As well as the version of httpd you are trying against, as well as how
  > it was built/configured.

1.3.39 with BenSSL (apache_1.3.37+ssl_1.57.tar.gz). I did not
configure anything myself and let it be built by mod_perl. The BenSSL
part is just an extra hurdle that you can avoid for sure.

  > Same thing for mod_perl.

    - USE_APACI=1
    - APACHE_PREFIX=/usr/local/apache-1.3.39
    - APACI_ARGS=--enable-module=info,--enable-module=status
    - APACHE_SRC=/home/src/apache_1.3.39/src
    - APACHE_SRC_DEFAULT=/home/src/apache_1.3.39/src
    - DO_HTTPD=1

  > Getting the exact argument you used to build/configure these might allow
  > me to reproduce, and hopefully, to fix as well.

Let me know if you need more or if you need a login.


View raw message