perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Elser <mel...@gmx.ch>
Subject Apache2::Subprocess not fully working on Windows XP?
Date Tue, 23 Oct 2007 11:37:57 GMT
Hi,

I'm using Apache2.2 precompiled binary on my Windows XP Professional
with ActivePerl 5.8.8 and mod_perl 2.0.3.

Problem is I want to start a subprocess from within a mod_perl handler.
I tried the example from the mod_perl site for the Apache2::SubProcess
module by using $r->spawn_proc_prog($prog,\@args);

Problem is I couldn't get it working fully. First thing I noticed, is
that using "/path/to/my/script.pl" doesn't work, because .pl scripts are
not directly executable like in linux distros and I get an OS error in
the apache log. If I just use 'c:\not_existing.exe' as $prog then
spawn_proc_prog throws another OS Error that the file
'c:\not_existing.exe' does not exist. So at spawn_proc_prog tries to do
something.

So I tried 'c:\perl\bin\perl.exe' as $prog and
'c:\Programme\ElserTextil\control\background_process.pl' as first
parameter. When doing this, no more errors were thrown, but the perl
program wasn't started either. I also experimented with the slashes, I
tried 'c:/perl/bin/perl.exe' and also 'C:\\perl\\bin\\perl.exe' but
nothing helped.

I also tried starting other programs like
'c:\WINDOWS\system32\notepad.exe' or '"c:\Programme\Microsoft
Office\Office11\Winword.exe"' with $prog, and also no errors were thrown
in the logfile, but none of the programs were started.

Can anyone please help me how to start a detached background process in
win32? I'm really out of ideas!

Thanks a lot

Marc




Mime
View raw message