perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manoj Bist" <manoj.bi...@gmail.com>
Subject Re: seg faults when running modperl and GD::Graph
Date Wed, 05 Sep 2007 05:13:04 GMT
One option would to be run apache under single threaded mode(option
-X) under gdb  and see where it is crashing.  Once you identify the
.so where it is crashing, you can try reproducing the crash outside
apache context.

If you suspect it to be a memory corruption issue you can try running
apache under valgrind.

On 9/4/07, Matt Williamson <matt@sanasecurity.com> wrote:
> I don't think it can be php.
>
> I disabled php on the server, and I still get the seg faults
>
> [Tue Sep 04 21:45:19 2007] [notice] Apache/2.0.55 (Ubuntu)
> mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
>
>
> [Tue Sep 04 21:45:29 2007] [notice] child pid 18466 exit signal
> Segmentation fault (11)
> [Tue Sep 04 21:45:30 2007] [notice] child pid 18467 exit signal
> Segmentation fault (11)
> [Tue Sep 04 21:45:32 2007] [notice] child pid 18468 exit signal
> Segmentation fault (11)
>
> Any other ideas?
>
> Matt
>
>
>
> > -----Original Message-----
> > From: Rafael Caceres [mailto:rcaceres@aasa.com.pe]
> > Sent: Tuesday, September 04, 2007 1:38 PM
> > To: Matt Williamson
> > Cc: modperl@perl.apache.org
> > Subject: Re: seg faults when running modperl and GD::Graph
> >
> > If you have PHP (with mod_php) enabled on that server, that's the
> > culprit and it can be fixed by compiling PHP without GD support.
> >
> > On Tue, 2007-09-04 at 13:12 -0700, Matt Williamson wrote:
> > > I noticed that my server is segfaulting when I run a script using
> > > GD::Graph
>
>

Mime
View raw message