perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Foo JH <jhfoo...@extracktor.com>
Subject Re: SV: [mp2+Win32] Frustration over Apache 2.0/ 2.2 restart failure
Date Sat, 11 Aug 2007 18:03:44 GMT
Hello Perrin, William

Unfortunately I'm packaging a product based on modperl, so I can't 
really take any shortcuts on this one.

William, my installation process is (what I hope to be) straight out of 
the book. To elaborate:
1. Install ActiveState Perl MSI 5.8.8 (build 822)
2. Install Apache2.2.4 MSI
3. Install modperl as per documentation on httpd.apache.org. Ie: perl 
install http://theoryx5.uwinnipeg.ca/ppms/mod_perl.ppd
4. Install libapreq from theoryx5

In my http.conf, I only added the following:
LoadFile c:/Perl/bin/perl58.dll
LoadModule perl_module modules/mod_perl.so

LoadFile bin/libapreq2.dll
LoadModule apreq_module modules/mod_apreq2.so

Apache/ modperl starts up fine, but if I try to restart the service, it 
will not survive.

Please share with me any tips to improve the situation. I'm open to any 
ideas.

Thanks.



Perrin Harkins wrote:
> On 8/10/07, Foo JH <jhfoo-ml@extracktor.com> wrote:
>   
>> The sad truth is that my clients are more comfortable with Windows OS
>>     
>
> Is it possible that if they have a small enough site to run
> comfortably on Windows, they can run it through CGI?  I suspect that
> whatever issue you're having with mod_perl could be fixed, but it
> seems pointless to fight with it if the site has low traffic and can
> run as CGI.
>
> - Perrin
>   


Mime
View raw message