perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Foo JH <jhfoo...@extracktor.com>
Subject Re: SV: [mp2+Win32] Frustration over Apache 2.0/ 2.2 restart failure
Date Fri, 10 Aug 2007 08:31:10 GMT
Hello Henrik,

Yes we have conversed earlier and shared the pain on this same point. My 
FreeBSD installations were relatively painless in comparison to the 
Win32 counterparts.

The sad truth is that my clients are more comfortable with Windows OS, 
and I have to support our products on this platform. It's either I get 
modperl to work, or we have a product overhaul to move over to .NET 
(which I hope will not happen).

It's quite strange that nobody else has this problem. It's definately a 
critical operational concern. I am starting to suspect that Perl/ 
modperl is quietly exclusive to the non-Windows world.

I hope someone in this community can prove me wrong...

Henrik Schak Hansen wrote:
> Hi Foo
>
> I finally gave up on Apahce/modperl2 on win32 in various version
> combinations. I kept hoping that newer versions of apache/modperl would
> stabilize it but rather it seemed to get worse. Daily apache/modperl
> would fail and modperl would restart maybe 10 time within a few minutes
> before finally working again. Only because I have a load balancer in
> front of several web servers have I been able to keep going.
> Anyway, now I have moved to Linux a week ago, and so fare I haven't
> experienced any problems (except having to tweak different parameters).
> So I cross my fingers and hope it will stay this way.
>
> Not much of help for you I know, but I remember we have talked about
> this before....
>
> Regards
> Henrik Schak Hansen
>
>
>
>
> -----Oprindelig meddelelse-----
> Fra: Foo JH [mailto:jhfoo-ml@extracktor.com] 
> Sendt: 10. august 2007 10:10
> Til: modperl@perl.apache.org
> Emne: [mp2+Win32] Frustration over Apache 2.0/ 2.2 restart failure
>
> Hi all,
>
> I am rather disappointed (and a little frustrated as well) on modperl's
> inability to survive an Apache restart on the Windows platform. The
> platform combo tested are Windows 2003 + Apache 2.2 (and Apache 2.0) +
> modperl2 + libapreq2
>
> I have come to accept the fact that once in a while modperl on Win32
> will segfault, but the old Apache I tried (year 2005 iirc) seems to
> recover, though it threw a windows fault dialog that scared the wits out
> of my clients. But this time it's just unacceptable. The odd thing is,
> if you try to start apache after it failed, it will fail again. You have
> to wait about a minute (or more) before starting the server.
>
> I don't mind any creative workarounds. Please share with me any
> suggestions or tips that can circumvent this. Thanks much.
>
>
> -------
> [Denne E-mail blev scannet for virus af Declude Virus]
> [This E-mail was scanned for viruses by Declude Virus]
>
>   


Mime
View raw message