perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Peters <mpet...@plusthree.com>
Subject Re: php/mod_perl + mysql woes
Date Fri, 20 Jul 2007 12:44:11 GMT
Dustin D. wrote:
> I can't seem to get php 5.2.3, mod_perl 2.0.3, mysql 5.0.45, and apache
> 2.2.4 to work together. 

Why do you need to do that? Normally what I've seen others do in this situation
(and have done myself) is to have 2 separate apaches and a proxy in front of
them to send it to one or the other. For some reason, some people are hesitant
to run multiple versions of apache on the same machine, but there are lots of
people who do it all the time and it works out just fine.

If you're concerned about running 3 apaches (1 for mod_perl, 1 for PHP and 1 for
the proxy) then you can use a smaller lightweight proxy like squid.

-- 
Michael Peters
Developer
Plus Three, LP


Mime
View raw message