perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dustin D." <dustin.devr...@gmail.com>
Subject php/mod_perl + mysql woes
Date Fri, 20 Jul 2007 05:50:11 GMT
I can't seem to get php 5.2.3, mod_perl 2.0.3, mysql 5.0.45, and apache
2.2.4 to work together.  I've read countless websites and documentation,
followed all the different hints and tips, and I either end up with a
situation where mysql or php complain about mysql problems, or, if I install
php with the --with-mysql=/usr/local/mysql-5.0.45 option, I get the
following error when I restart apache:

[Thu Jul 19 23:23:47 2007] [notice] SIGHUP received.  Attempting to restart
[Thu Jul 19 23:23:47 2007] [notice] Digest: generating secret for digest
authentication ...
[Thu Jul 19 23:23:47 2007] [notice] Digest: done
[Thu Jul 19 23:23:48 2007] [notice] Apache/2.2.4 (Unix) DAV/2 PHP/5.2.3
mod_perl/2.0.3 Perl/v5.8.5 configured -- resuming normal operations
*** glibc detected *** malloc(): memory corruption: 0x0000000000be58f0 ***
*** glibc detected *** malloc(): memory corruption: 0x0000000000be58f0 ***
*** glibc detected *** malloc(): memory corruption: 0x0000000000be58f0 ***
*** glibc detected *** malloc(): memory corruption: 0x0000000000be58f0 ***
*** glibc detected *** malloc(): memory corruption: 0x0000000000be58f0 ***
[Thu Jul 19 23:23:49 2007] [notice] child pid 27006 exit signal Aborted (6)
[Thu Jul 19 23:23:49 2007] [notice] child pid 27007 exit signal Aborted (6)
[Thu Jul 19 23:23:49 2007] [notice] child pid 27008 exit signal Aborted (6)
[Thu Jul 19 23:23:49 2007] [notice] child pid 27009 exit signal Aborted (6)
[Thu Jul 19 23:23:49 2007] [notice] child pid 27010 exit signal Aborted (6)
*** glibc detected *** malloc(): memory corruption: 0x0000000000be58f0 ***

FYI, I Iinstalled apache 2.2.4 and then mod_perl 2.0.3.  After installing
mod_perl, everything was working fine, minus the PHP support I need.

So, next, I tackled the php installation, using php 5.2.3 and the following
configuration line:

./configure --with-apxs2=/usr/local/apache2.2.4/bin/apxs
--prefix=/usr/local/apache2.2.4/php
--with-config-file-path=/usr/local/apache2.2.4/php
--enable-force-cgi-redirect --disable-cgi --with-zlib  --with-gettext
--with-mysql=/usr/local/mysql-5.0.45

This installed cleanly, but then I get the errors listed above.

Both PHP and mod_perl are being installed as DSO.  Should I be installing
one or the other as static?

If I exclude the --with-mysql statement from php, then between php and
mod_perl, whoever is listed first with the LoadModule line in httpd.conf is
able to use mysql, while the other complains with mysql errors (unable to
make connections).  I know there are issues with mysql working with both php
and mod_perl, and supposedly they're fixed by installing php with the
--with-mysql option.  I've followed those directions to the T and now I get
these annoying glibc/child pid abort errors.

I searched through the archives of the mailing list fairly extensively, and
couldn't find anything.  I also couldn't find anything online.

Can someone help?  I've been going for the past three evenings trying to get
this to work, and I'm exhausted and defeated.

Thanks,
Dustin

Mime
View raw message