perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Field" <...@brantaero.com>
Subject [mod_perl2] PerlSwitches having no effect?
Date Wed, 18 Jul 2007 14:14:54 GMT
Hi everyone,

I'm running Apache 2.2 with mod_perl2 on Win2k3sp2.  I'm new to the mp/
mp2 world but have been working with it the last couple weeks, and am 
fairly familiar with the docs and list archives, but for some reason I 
can't figure out the following problem: PerlSwitches doesn't seem to do 
anything.

Right before all the other LoadModules lines in my configuration file I 
have:

PerlSwitches -wT
LoadFile "C:\Perl\bin\perl58.dll"
LoadModule perl_module modules/mod_perl.so

I have a script that uses "my" and therefore runs into that wonderful 
inner subroutine problem.  This ought to generate warnings.  If I put

use warnings;

...at the beginning of said script, I *do* get all the appropriate 
warnings.  But I take that away, and the -w in my configuration file 
seems to not be doing anything, because I get no messages in the log 
(just a script that behaves strangely, of course :P .)  (I suspect 
taint checking might also not be properly enabled, given that my 
sketchy preliminary whitelisting untaint function doesn't use regexes 
or any magic, yet Perl does not complain.)

I have wracked my brain and searched for everything I could think of, 
but to no avail.  I've tried moving the PerlSwitches statement around 
in the file: middle, end, whatever, no dice.  I've tried plain -w.  And 
yes I've restarted Apache for each attempt.

Cluestick coming my way?  Anyone?

Thanks for your time,
Kev

Mime
View raw message