perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Octavian Rasnita" <orasn...@gmail.com>
Subject Can't install mod_perl
Date Fri, 13 Jul 2007 15:48:40 GMT
Hi,

I am trying hard to install mod_perl under SuSE X86_64 but I cannot do it.

It gives the error below on the "make" step. I have searched for this error 
on the net, and I found only that perl could be badly installed, or Apache.

I installed perl using the /lib64 /usr/lib64 and /usr/local/lib64 
directories and not the default (/lib /usr/lib and /usr/local/lib).
I have also chose to install it with 64 bit support.

The problem is that I don't know how to be sure that Apache is installed 
with 64 bit support.

I have also tried by installing Active Perl for Linux X86_64 which I guess 
it was compiled correctly, but it gave the same error on the "make" step for 
mod_perl.
First I installed perl using default libraries (from /lib, /usr/lib...) and 
I wasn't able to compile DBD::mysql. After using /lib64, /usr/lib64... I was 
able to compile DBD::mysql, so I think perl is installed correctly.

This is why I think Apache is not installed as it should, but I don't know 
how to install it with 64 bit support.

Please tell me, have you succeeded to install mod_perl under a X86_64 
machine? If yes, please advice what should I do.

If you didn't, do you know if a 32 bit Linux OS can be installed under a 64 
bit machine? Is it adviceable to do this for a production machine?

If it helps, here is the result of `uname -a`:
Linux duahp 2.6.16.13-4-smp #1 SMP Wed May 3 04:53:23 UTC 2006 x86_64 x86_64 
x86_64 GNU/Linux

Thank you very much.

Here is the error:

duahp:/usr/local/src/mod_perl-2.0.3 # make
cd "src/modules/perl" && make
make[1]: Entering directory `/usr/local/src/mod_perl-2.0.3/src/modules/perl'
rm -f mod_perl.so
gcc -shared \
 \
mod_perl.lo modperl_interp.lo modperl_tipool.lo modperl_log.lo 
modperl_config.lo modperl_cmd.lo modperl_options.lo modperl_callback.
lo modperl_handler.lo modperl_gtop.lo modperl_util.lo modperl_io.lo 
modperl_io_apache.lo modperl_filter.lo modperl_bucket.lo modperl
_mgv.lo modperl_pcw.lo modperl_global.lo modperl_env.lo modperl_cgi.lo 
modperl_perl.lo modperl_perl_global.lo modperl_perl_pp.lo mod
perl_sys.lo modperl_module.lo modperl_svptr_table.lo modperl_const.lo 
modperl_constants.lo modperl_apache_compat.lo modperl_error.lo
 modperl_debug.lo modperl_common_util.lo modperl_common_log.lo 
modperl_hooks.lo modperl_directives.lo modperl_flags.lo modperl_xsini
t.lo modperl_exports.lo  -Wl,-E 
  /usr/local/perl_588/lib/CORE/libperl.a -lnsl -ldl -lm -lcrypt -lutil -lpthread 
 -lc \
-o mod_perl.so
/usr/lib64/gcc/x86_64-suse-linux/4.1.0/../../../../x86_64-suse-linux/bin/ld: 
/usr/local/perl_588/lib/CORE/libperl.a(gv.o): relocatio
n R_X86_64_32S against `a local symbol' can not be used when making a shared 
object; recompile with -fPIC
/usr/local/perl_588/lib/CORE/libperl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [mod_perl.so] Error 1
make[1]: Leaving directory `/usr/local/src/mod_perl-2.0.3/src/modules/perl'
make: *** [modperl_lib] Error 2
duahp:/usr/local/src/mod_perl-2.0.3 #
Ready ssh2: AES-12  21,  39  52 Rows, 132 Cols VT100
Octavian


Mime
View raw message