perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Vanasco <jvana...@2xlp.com>
Subject Re: apache version check
Date Tue, 19 Jun 2007 00:44:00 GMT

On Jun 18, 2007, at 5:05 PM, John ORourke wrote:


>    $version = ( $ENV{MOD_PERL_API_VERSION}==2 )?2:1;

that won't work, because that requires mod_perl to be loaded.

the original poster said:

	"How do I check what version of Apache is installed from command  
line (without using/lodaing mod_perl)?"

and then said:
	
	"When I don't know where apache is installed, how do I do this? I  
was asking for a way to write a perl script that would give me the  
version of apache installed, if possible!"

since its command line, he needs to figure out which apaches are on  
the system, and then test the versions on them.  there's no other way.

Mime
View raw message