perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sravan Garlapati <srgar...@cisco.com>
Subject RE: mod_perl not loading into apache error.
Date Tue, 22 May 2007 06:52:05 GMT
 
Hi Friends,

I am unable to install mod_perl-2.0.3 in my system(Windows). 

I am using apache version 2

Perl version 5.6.1.

I have given from DOS command prompt.

I put mod_perl-2.03 directory and its file in C:\Perl

C:\Perl\mod_per-2.0.3> Perl makefile.pl APACHE_SRC=C:\Program Files\Apache
Group\Apache2

When I run this its giving error. It require high version of perl >= 5.8

Thanks 
Sravan

-----Original Message-----
From: Nick Pron [mailto:djfishy@gmail.com] 
Sent: Tuesday, May 22, 2007 10:54 AM
To: modperl@perl.apache.org
Subject: Re: mod_perl not loading into apache error.


Yes I'm positive. I didn't install Apache or mod_perl with the package
manager, the only thing that came packaged installed was Perl.
I just tried installing mod_perl with the package mananger anyway, it didn't
find anything to upgrade (it wanted a fresh install of it) so that's how I
know it's not already there.


Fred Moyer wrote:
> 
> Nick Pron wrote:
>> Hi all,
>> 
>> I am on a fresh install of Ubuntu 7.04 with Apache 2.2.4 compiled 
>> from source. Perl v5.8.8 built for i486-linux-gnu-thread-multi (came 
>> with Ubuntu as a package I assume) and I am getting this error when I 
>> try to start Apache.
>> 
>> httpd: Syntax error on line 54 of /usr/local/apache/conf/httpd.conf:
>> Cannot
>> load /usr/local/apache/modules/mod_perl.so into server:
>> /usr/local/apache/modules/mod_perl.so: undefined symbol: PL_vtbl_env
> 
> Are you sure that mod_perl isn't already installed with Ubuntu's 
> package manager?  If so then remove it, and re-install mod_perl from
source.
> That's usually the source of unresolved symbol bugs like this.
> 
> See this link for a really interesting one:
> 
> http://www.gossamer-threads.com/lists/modperl/modperl/73816
> 
> 

--
View this message in context:
http://www.nabble.com/mod_perl-not-loading-into-apache-error.-tf3794200.html
#a10731723
Sent from the mod_perl - General mailing list archive at Nabble.com.

Mime
View raw message