perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop kumar V" <anoopkum...@gmail.com>
Subject Re: mod_perl installation problem
Date Fri, 02 Mar 2007 15:36:28 GMT
On 3/2/07, Randy Kobes <randy@theoryx5.uwinnipeg.ca> wrote:
>
> On Fri, 2 Mar 2007, Anoop kumar V wrote:
>
> > Is it expected that the apachemonitor breaks when mod-perl is installed.
> >
> > After I did the below steps, I can start Apache from the commandline,
> but
> > when I try using the ApacheMonitor tool from my task tray, it says the
> same
> > thing that "The requested operation has failed"
> >
> > I tested this with smilar results on both Apache/2.2.4 (Win32) and
> > Apache/2.0.59.
>
> If Apache starts from the commandline OK, and works, then
> it must be something with ApacheMonitor. Does ApacheMonitor
> work without mod_perl enabled? You might also check that
> you have the proper permissions - for example, if things
> are set up to start Apache as a service, you (as the user
> you're logged in as) may not have permission to start
> Apache. If you can, log in as the Administrator to see
> if that works.
>
> --
> best regards,
> Randy
>

Yes - I checked that - without mod_perl enabled, with a vanilla Apache
installation (and with weblogic module enabled), the apachemonitor starts
and stops apache fine. With the mod_perl line: (LoadModule .....) in
httpd.conf it errors out. If I remove the line it again works flawlessly.
The thing is this breaks in both the apache versions I mentioned above...

I am the administrator on this Win XP machine.

Its not a big issue - since apache runs fine from the commandline, but it
would have been great if I could manage from the monitor, else I need to
keep cmd prompt window open just for this thing...

-- 
Thanks and best regards,
Anoop

Mime
View raw message