perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jordan McLain" <jordan.mcl...@gmail.com>
Subject Re: Have I got mod_perl installed?
Date Thu, 01 Mar 2007 00:53:27 GMT
I had the same problem with 0.69... I just used 0.66 instead:

http://sourceforge.net/project/downloading.php?groupname=soaplite&filename=SOAP-Lite-0.66.tar.gz&use_mirror=superb-west

Jordan Mclain
eCarList.com

On 2/28/07, Juan Jose Natera <naterajj@gmail.com> wrote:
>
> > I was trying `perl -MCPAN -e 'install SOAP::Apache'.
>
> That actually tries to install SOAP::Lite
>
> > t/06-modules...........NOK 15# Failed test 15 in t/06-modules.t at
> > line 24 fail #14
> > #  t/06-modules.t line 24 is:   $@ =~ /(Can\'t
> > locate)|(XML::Parser::Lite requires)|(this is only version)|(load
> > mod_perl)/
>
> It seems SOAP::Lite once installed knows how to handle the different
> versions of mod_perl (including 1.99_X).
>
> However, when you attempt to install SOAP::Lite if you tell it you
> want an Apache/ModPerl SOAP server, it tries to install mod_perl 1.2X,
> so my suggestion would be to tell it you _don't_ want Apache/mod_perl
> support, it will install the transport modules anyway.
>
>
> > the load mod_perl is what concerns me and during the install it said
> > that mod_perl wasn't installed.
> >
> > I am tempted to install from source but I am nervous about crippling
> > my installation as it's a live system.
>
> Tell CPAN where you want your modules installed:
>
> # perl -MCPAN -e shell
> cpan> o conf makepl_arg PREFIX=/usr/local/whatever
> cpan> o conf commit
>
> Then you can adjust @INC via your preferred method.
>
> Still, I would recommend testing it in another machine and asking at
> the SOAP::Lite users mailing list, since that's where the problem
> seems to be.
>
> Juan
>

Mime
View raw message