perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tracy12 <j_lal...@yahoo.com>
Subject functionality works / but test failed
Date Mon, 15 Jan 2007 08:51:07 GMT

Hi,

I am in the process of changing a perl module written to a Perl
Authentication handler.

Well when I try to deploy the module it failed in the  ' make test' stage
all the other steps went ok.
But the functionality works as expected.


When we execute make test it gives the following error

Failed Test Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/00.load.t    1   256     1    1 100.00%  1
2 tests skipped.
Failed 1/3 test scripts, 66.67% okay. 1/1 subtests failed, 0.00% okay.
make: *** [test_dynamic] Error 255


I found out that the reason for failure is the following line

use Apache2::compat;

but when I remove this entry the make test gives no errors but functionality
fails and in the log it says that
 Can't locate object method "user" via package "Apache2::Connection" at
/usr/lib/perl5/site_perl/5.8.8/AuthCAS.pm line 512.\n

which is basically   $r->connection->user($user);
line in the source.



Also in the in the 't' folder the source of the 00.load.t is as follows

use Test::More tests => 1;

BEGIN {
use_ok( 'AuthCAS' );
}

diag( "Testing AuthCAS $AuthCAS::VERSION" );


Let us know how to get around with this,








-- 
View this message in context: http://www.nabble.com/functionality-works---but-test-failed-tf3013374.html#a8368294
Sent from the mod_perl - General mailing list archive at Nabble.com.


Mime
View raw message