perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Maas <frank.m...@cheiron-it.nl>
Subject Re: MP 2.0.3 & Apache 2.2.3 -> auth tests fail
Date Mon, 15 Jan 2007 22:07:27 GMT
On Sat, Jan 13, 2007 at 02:52:03PM -0500, Perrin Harkins wrote:
> Frank Maas wrote:
> >I have installed version 2.2.3 of apache and want to install
> >2.0.3 of MP. Compiling it gives no problems, but 'make test' fails on
> >four files. All fail on the authentication phase - the httpd-errorlog 
> >shows 'couldn't check access. No groups file?'.
> 
> There were changes in apache's auth system in version 2.2.  I don't know 
> if that's what's causing this, but it could be.  Is there a reason you 
> can't use 2.0.x?

I replied to Perrin directly on this (sorry for wandering of the list), 
but you missed nothing interesting there.

Based on Perrins assumption I checked back en forth in the MP internals, 
but found no reason why the behaviour was as it was. I then discovered 
2.2.4, downloaded it and bingo - no problems. When I looked at what I 
thought to be the relevant files I found no relevant changes that could 
explain why 2.2.4 works. A bold remark: could it be that having tried to 
install MP 2.0.3 while having MP 2.0.3 RC1 installed did the dirty trick?

Back to 2.2.4 - MP2.0.3 worked with one alteration. It seems that 
ap_get_server_version is not only depreciated, but also changed 
functionality. That is... one test fails because it calls 
get_server_version, expects "Apache 2.2.4  (Unix)" but gets "Apache 
2.2.4". This can be solved by applying the following patch:

--- xs/Apache2/ServerUtil/Apache2__ServerUtil.h.orig    2007-01-15 22:16:52.000000000 +0100
+++ xs/Apache2/ServerUtil/Apache2__ServerUtil.h 2007-01-15 22:15:52.000000000 +0100
@@ -194,5 +194,5 @@
                 newSVpv(ap_get_server_built(), 0));

     newCONSTSUB(PL_defstash, "Apache2::ServerUtil::get_server_version",
-                newSVpv(ap_get_server_version(), 0));
+                newSVpv(ap_get_server_description(), 0));
 }


But note that this is not a backwards compatible patch. For 2.0.x this 
won't work and even for 2.2.x with x < 4 this fails. I tried to look for a 
version dependent solution, but did not find any. And for what its worth: 
it might be better to depreciate server_version in MP2 as well and replace 
it for server_banner and server_description.

Regards,
Frank

Mime
View raw message