perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Georg Grabler" <ggrab...@gmail.com>
Subject Problem with MODPERL_API_VERSION
Date Wed, 27 Dec 2006 11:46:15 GMT
Hello everybody around.

I've a strange problem occuring on my computer.

I've taken the script from the apache mod_perl documentation, pringing
my environment variables (${ENV}).
According to this, my MOD_PERL_API_VERSION is 2, what's fine so far.

Anyway, accessing them from ANY module, with the following code:
MOD_PERL: {
    ( (exists $ENV{MOD_PERL_API_VERSION}) &&
      ($ENV{MOD_PERL_API_VERSION} == 2) ) and do {

does not work at all. If i print within the die message
$ENV{MOD_PERL_API_VERSION} nothing is displayed (undef? or '', i dont
know).

This is NOT my code, but the code failing at the moment. It's taken
out (once again) from the SOAP::Lite CPAN module.

Everywhere is documentated that this actually is the way to write
mod_perl modules for mod_perl 2.x. Why can this fail? How?

Any ideas? Did i miss to compile something, did i miss something in my
apache config for mod_perl to be loaded, so my environment is set
correclty?

Thank you,
Georg

Mime
View raw message