perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Foo JH <jhfoo...@extracktor.com>
Subject Unable to compile libapreq2
Date Wed, 20 Sep 2006 07:29:41 GMT
Hi guys,

I'm using FBSD6.0. I've done the latest cvsup on the ports, installed 
apache 2.0.59 and mod_perl 2.0.2,3 and and trying to install 
libapreq2-2.0.08.

Halfway through the compilation, I get this error:
cc -shared  .libs/util.o .libs/version.o .libs/cookie.o .libs/param.o 
.libs/parser.o .libs/parser_urlencoded.o .libs/parser_header.o 
.libs/parser_multipart.o .libs/module.o .libs/module_custom.o 
.libs/module_cgi.o .libs/error.o  -Wl,--rpath -Wl,/usr/local/lib/apache2 
-Wl,--rpath -Wl,/usr/local/lib/apache2 
/usr/local/lib/apache2/libapr-0.so 
/usr/local/lib/apache2/libaprutil-0.so -lexpat -liconv -lm -lcrypt 
-L/usr/local  -Wl,-soname -Wl,libapreq2.so.8 -o .libs/libapreq2.so.8
/usr/bin/ld: cannot find -lexpat
gmake[2]: *** [libapreq2.la] Error 1
gmake[2]: Leaving directory 
`/usr/ports/www/libapreq2/work/libapreq2-2.08/library'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory 
`/usr/ports/www/libapreq2/work/libapreq2-2.08/library'
gmake: *** [all-recursive] Error 1

I've tried recompiling expat, but that did not change the problem.

Can any kind soul please drop some hints as to what may be the problem? 
Thanks.


Mime
View raw message