perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Wray" <Simon.W...@Xchanging.com>
Subject [mp2] 'Can't Load...' PerlRequire error for Apache2.2
Date Thu, 25 May 2006 08:51:33 GMT
Hi all... I'm hoping you can help me with a problem I have configuring
mod_perl2.

 

I'm completely new to Apache & Perl and am attempting to use them on an
office XP SP2 machine so I can load the ASP.Net module and try that out.
I'm mainly a VB, HTML & CSS person, so I'm in foreign territory with all
this server-side stuff! I'm trying to load the Perl module because I
believe it's a requirement for the ASP.Net module.

 

I've been following the "Configuring mod_perl 2.0 for Win32"
instructions at http://perl.apache.org/docs/2.0/os/win32/config.html. So
far I have installed Apache2.2 and ActivePerl (latest) along with the
Perl5.8 module.

 

I have amended my conf file as follows:

 

LoadFile "C:/Perl/bin/perl58.dll"

LoadModule perl_module modules/mod_perl-2.2.so

PerlRequire "C:/Program Files/Apache Software
Foundation/Apache2.2/conf/extra.pl"

 

The problem I am getting is this error when I try to restart the server:

 

[Thu May 25 09:20:56 2006] [error] Can't load Perl file: C:/Program
Files/Apache Software Foundation/Apache2.2/conf/extra.pl for server
WS000665.ad.Xglobal.com:80, exiting...

 

So the problem seems to be with the PerlRequire line in the conf file -
when I comment this out the server starts with no errors.

 

Apache is installed here: C:/Program Files/Apache Software
Foundation/Apache2.2

Perl is installed here: C:/Perl

My Perl module is indeed called: mod_perl-2.2.so

The extra.pl script is located at: C:/Program Files/Apache Software
Foundation/Apache2.2/conf/extra.pl

...and contains:

 

----------

use ModPerl::Util ();

use Apache2::RequestRec ();

use Apache2::RequestIO ();

use Apache2::RequestUtil ();

use Apache2::ServerRec ();

use Apache2::ServerUtil ();

use Apache2::Connection ();

use Apache2::Log ();

use Apache2::Const -compile => ':common';

use APR::Const -compile => ':common';

use APR::Table ();

use Apache2::compat ();

use ModPerl::Registry ();

use CGI ();

1;

----------

 

Can anyone please offer me a solution to the error message I am
receiving or any advise as to how I should progress?

 

Thanks

Simon Wray
Senior Software Engineer

Xchanging
Endeavour Drive, Basildon, Essex SS14 3WF

Direct: +44 (0)1268 643864
Home: +44 (0)1702 600488
Fax: +44 (0)1702 353276
Email: simon.wray@xchanging.com
Web: http://www.xchanging.com/

The contents of this email are confidential to the ordinary user of the
e-mail address to which it was addressed and may also be privileged. If
you are not the addressee of this e-mail you may not copy, forward,
disclose or otherwise use it or any part of it in any form whatsoever.
If you have received this e-mail in error please e-mail the sender by
replying to this message.

 


Mime
View raw message