perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hal Vaughan <...@thresholddigital.com>
Subject Re: Problems With mod_perl on Apache 2.0
Date Tue, 04 Apr 2006 05:09:48 GMT
Tom Williams wrote:

> Hal Vaughan wrote:
>> I'm using Apache 2.0 on Debian Linux.  I've installed mod_perl and I can
>> see
>> the links for perl.load and perl.conf in /etc/apache2/mods_enabled.  My
>> perl.load is like this:
>>
>> LoadModule perl_module /usr/lib/apache2/modules/mod_perl.so
>>
>> <Directory /var/www/perl >
>>    SetHandler  perl-script
>>    PerlResponseHandler ModPerl::Registry
>> </Directory>
>>
>> I've also tried "/perl" for the directory, but it makes no difference. 
>> At
>> this point I'm not doing anything fancy.  I just need to test some
>> scripts
>> that will later be uploaded to a server.  At this point, I just need to
>> get it working on my own system quickly so I can get a few scripts tested
>> (as opposed to writing, uploading, testing, then editing, uploading...).
>>
>> I've searched on this, but not found much helpful on it.  When I point my
>> browser to http://localhost/perl/script, I get the source for the script.
>> If I add ".pl" to the script name and put that in the browser address
>> bar, Firefox tries to download the program.
>>   
> I've had to use this code to get mod_perl working with perl scripts on
> my Apache 2 server:
> 
>         <Location [location here]>
>                 SetHandler perl-script
>                 PerlResponseHandler ModPerl::Registry
>                 PerlOptions +ParseHeaders
>                 Options +ExecCGI
>         </Location>
> 
> Read this:
> 
>
http://perl.apache.org/docs/2.0/user/intro/start_fast.html#Registry_Scripts
> 
> which I found on this page:
> 
> http://perl.apache.org/docs/2.0/user/config/config.html
> 
> in the "Enabling mod_perl" section.
> 
> Good luck!
> 
> Peace...
> 
> Tom

Thanks.  After experimenting and not getting it to work, I finally purged
apache2, apache2-common and lib-apache2-mod-perl2 (those are the Debian
package names), made sure all the config files were deleted, then
re-installed all three and used your config for perl.load.  It worked fine.

Thank you.

Hal


Mime
View raw message