perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Russell <...@onlywebdata.com>
Subject Re: pnotes MP1->MP2
Date Mon, 03 Apr 2006 20:34:11 GMT
Geoff,

Sorry I'm not familiar with Apache2::TestModperl

search.cpan.org gives no hits for Apache2 TestModperl

How do I use this test to identify the problem with
MP2 pnotes?

I'm using
httpd-2.0.55
mod_perl-2.0.2
but can work with any trusted version.

If I comment out the line

# my $dbh = $r->pnotes('DBH');

and the problem goes away when the only use of the
$dbh has been DBI->connect how can I identify where
else the fault is in my code if it worked previously
under MP1?

Sorry to bother you with this,
John.

On Apr 3, 2006, at 12:25 PM, Geoffrey Young wrote:

>
>
> John Russell wrote:
>> In MP1 it was possible to do..
>>
>> Authorization Phase
>>
>> sub handler {
>>
>>   my $dbh;
>>
>>   $dbh = DBI->connect(..)
>>       || return "Error connecting.\n $DBI::errstr\n";
>>
>>   $r->pnotes(DBH => $dbh);
>>
>>
>> Response Phase
>>
>> sub handler($$) {
>>
>>   my $dbh = $r->pnotes('DBH');
>>
>> However this doesn't work in MP2 because $dbh is a hash
>
> as indicated by others here, the problem rests elsewhere in your  
> code and
> not with pnotes() proper.
>
> nevertheless, I've added some tests to our pnotes tests to verify  
> that $dbh
> does indeed currently work and doesn't ever loose its blessed magic  
> during
> our storage process.
>
>   http://svn.apache.org/viewcvs?rev=391122&view=rev
>
> --Geoff
>






Mime
View raw message