perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cory Omand" <com...@blastwave.org>
Subject Re: Apache 2.2 and libapreq2 2.0.7 segfault
Date Thu, 30 Mar 2006 01:22:27 GMT
On 3/29/06, Philip M. Gollucci <pgollucci@p6m7g8.com> wrote:
> I hope this isn't whats causing it, but you're missing
>
> use Apache2::Const -compile qw(OK);
>
> I know we prefer the other way of new() so try doing this
> my $apr = Apache2::Request->new($r)
>
> I don't recall if we support both (as you can tell I've been out of it for a
> while).

The new Obj vs. Obj->new doesn't require any support from the module
itself, but I tried it just to be sure, and still get the same
segfault.  Also, I do compile constants in the startup.pl script, and
when I remove the call to Apache2::Request in my sample handler, the
segfault goes away.

> If that doesn't work,
> perl -V

Attached: perl.V.txt

> ./configure for PERL, httpd,

For perl, the non-path/compiler flag defines passed to Configure are:

-Duselargefiles
-Duseshrplib
-Dusesitecustomize
-Dusethreads

(Note: when I comment out the call to Apache2::Request in my example,
mod_perl happilly handles the request, so I think the perl/mod_perl
path is working fine.  The stack trace shows the segfault in
mod_apreq2.so)

Attached: httpd-2.2-config.nice

> Makefile.PL line for mod_perl and httpd-apreq

mod_perl:

perl Makefile.PL \
    MP_APXS=/path/to/apache2/sbin/apxs \
    MP_PROMPT_DEFAULT=1 \
    MP_DEBUG=1

httpd-apreq2:

perl Makefile.PL \
  --enable-perl-glue
  --with-perl=/opt/csw/bin/perl
  --with-apache2-apxs=/opt/csw/apache2/sbin/apxs
  --with-apr-config=/opt/csw/apache2/bin/apr-config
  --with-apu-config=/opt/csw/apache2/bin/apu-config
  --with-expat=/opt/csw
  --with-mm-opts="INSTALLDIRS=vendor"

Thanks,
Cory.

Mime
View raw message