perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher H. Laco" <cl...@chrislaco.com>
Subject Re: is there a way to force UTF-8 encoding
Date Fri, 03 Mar 2006 20:39:38 GMT
John N. Brahy wrote:
>> -----Original Message-----
>> From: Christopher H. Laco [mailto:claco@chrislaco.com]
>> Sent: Friday, March 03, 2006 12:28 PM
>> To: John N. Brahy
>> Cc: modperl@perl.apache.org
>> Subject: Re: is there a way to force UTF-8 encoding
>>
>> John N. Brahy wrote:
>>> Is there a way to force UTF-8 encoding? I have tried
>>>
>>> AddDefaultCharset utf-8 in the httpd.conf
>>>
>>> OS: OpenBSD
>>> Apache: Apache/1.3.29 (Unix) mod_perl/1.29 mod_ssl/2.8.16 OpenSSL/0.9.7g
>>>
>>> But
>>> 1) wget -S says it's Content-Type: text/html; charset=ISO-8859-1
>>> 2) when I try the HTML validator on w3c.org it tells me that it's
>>> ISO-8859-1
>>> 3) Internet Explorer and Firefox both have ISO-8859-1 selected
>>> 4) Firefox's Page Info shows it as ISO-8859-1
>>>
>>> Anybody know a way to force it to utf-8?
>> Are there actually any UTF-8 encoded characters in the output?
>> If their aren't any, then the document can really be both encodings at
>> the same time, unless of course the document also includes a BOM (Byte
>> Order Marker).
>>
>> -=Chris
> 
> Yes, it's a Spanish site that I'm developing for Verizon and they have characters that
show up incorrectly. 
> 
> http://www.verizonnoticias.com/ 
> 
> We've done most everything to encode into HTML entities but our client will need to copy
and paste from MS word so they will definitely have more of these characters. Sometimes they
show up as boxes and sometimes they show up as this character à even though it's actually
a &ntilde; 
> 
> 	

If you view the page in Firefox, and then manually select the UTF-8
encoding from View -> Character Encoding -> Unicode(UTF-8) ...does the
page then display correctly?


Mime
View raw message