perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Kelsch" <richard.kel...@napster.com>
Subject Re: 2 versions
Date Wed, 08 Mar 2006 20:12:04 GMT
On Tue, 2006-03-07 at 14:16 -0500, Perrin Harkins wrote: 

> On Tue, 2006-03-07 at 11:53 +0200, Octavian Rasnita wrote:
> > Is it possible to have 2 versions of perl that use mod_perl and libapreq?
> 
> Yes.  You just need to tell your new perl what path to live in when you
> build it.  I think the option is named "PREFIX."  Same for apache, and
> make sure you use the right perl when you build mod_perl.
> 
> > It would be also very very useful to have a way of upgrading to a new
> > version of perl and installing automaticly all the modules that the older
> > version of perl was using. Is there a way that I don't know?
> 
> There's something you can do with bundles that makes a list of the
> installed modules and then you can use that to reinstall them.  See the
> CPAN docs.


That would be "autobundle" inside the "cpan" utility.

Rich
   
   
   
This correspondence is from Napster, Inc. or its affiliated entities
and is intended only for use by the recipient named herein. This
correspondence may contain privileged, proprietary and/or confidential
information, and is intended only to be seen and used by named addressee(s).
You are notified that any discussion, dissemination,distribution or copying
of this correspondence and any attachments, is strictly prohibited, 
unless otherwise authorized or consented to in writing by the sender. 
If you have received this correspondence in error, please notify the 
sender immediately, and please permanently delete the original and any 
copies of it and any attachment and destroy any related printouts without 
reading or copying them.



Mime
View raw message