perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Perrin Harkins <per...@elem.com>
Subject Re: 2 versions
Date Tue, 07 Mar 2006 19:16:29 GMT
On Tue, 2006-03-07 at 11:53 +0200, Octavian Rasnita wrote:
> Is it possible to have 2 versions of perl that use mod_perl and libapreq?

Yes.  You just need to tell your new perl what path to live in when you
build it.  I think the option is named "PREFIX."  Same for apache, and
make sure you use the right perl when you build mod_perl.

> It would be also very very useful to have a way of upgrading to a new
> version of perl and installing automaticly all the modules that the older
> version of perl was using. Is there a way that I don't know?

There's something you can do with bundles that makes a list of the
installed modules and then you can use that to reinstall them.  See the
CPAN docs.

- Perrin


Mime
View raw message