perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Galbreath" <Galbrea...@gao.gov>
Subject Re: mod_perl 2.0.0 + Apache 2.0.55 on Cygwin Win2k3
Date Thu, 16 Feb 2006 13:47:13 GMT
A word of caution from personal experience here.
 
First, I love ActiveState' s stuff - I bought (out of my pocket) personal and pro licenses
for Komodo 3.2 and 3.5.  I run ActivePerl 5.8 and ActivePython 2.4 on my Winblows and Linux
boxes at home.  So what's the prob?
 
At the office, installing ActivePerl just annoyed the sysadmins because it didn't really break
anything but I found myself in the position of begin able to take advantage of some pretty
cool modules (like IO::ALL, e.g.) that have been upgraded or designed for 5.8 when the infrastructure
remains at 5.6.  I didn't think of this (doh!) until I tried deploying a little app I wrote
and found it wouldn't work.  Make sure your infrastructure will support your upgrade!
 
Second, and though way more serious for me but perhaps not for you, I did the same with ActivePython
and it broke all the system utilities on my Red Hat Enterprise 4 workstation.  This really
pissed off the sysadmins and raised flags with the Security folks.
 
Third, one of the linux support folks here told me they were not supporting ActiveState products
because the company was in the process of dissolving or being bought or something that made
service and support continuity questionable.  Can anybody confirm this?
 
Mark<-|->kraM

>>> Tom Schindl <tomAtLinux@gmx.at> 16-Feb-06 09:20:29 AM >>>

It's free ;-) http://www.activestate.com/

Tom

Jeff Pang wrote:
>> Why don't you try ActivePerl instead of cygwin ?
>  
> Is there any free version of ActivePerl£¿or how much should I pay for
> it?thanks.
> 
>     ----- Original Message -----
>     *From:* Jason J. Czerak <mailto:Jason.Czerak@minn.ppdi.com>
>     *To:* modperl@perl.apache.org <mailto:modperl@perl.apache.org>
>     *Sent:* Thursday, February 16, 2006 4:28 AM
>     *Subject:* mod_perl 2.0.0 + Apache 2.0.55 on Cygwin Win2k3
> 
>     I have an application that is based on Apache::ASP. Apache::ASP
>     requires Apache2::porting and Apache2::compat to be in the startup.pl.
> 
>     Everything is working very well. I some how got mod_perl to build
>     and running with out a segfault. This is good. The issue is when
>     startup.pl is called, either from the command line or within apache
>     I get this error:
> 
>     [Wed Feb 15 13:47:49 2006] [error] Can't load
>     '/usr/lib/perl5/site_perl/5.8/cygwin/auto/Apache2/ServerUtil/ServerUtil.dll'
>     for module Apache2::ServerUtil: No such process at
>     /usr/lib/perl5/5.8/cygwin/XSLoader.pm line 68.\n at
>     /usr/lib/perl5/site_perl/5.8/cygwin/Apache2/XSLoader.pm line
>     30\nCompilation failed in require at /u01/startup.pl line 4.\nBEGIN
>     failed--compilation aborted at /u01/startup.pl line 4.\nCompilation
>     failed in require at (eval 2) line 1.\n
> 
>     Suggestions?
> 
>     I have also have this some what working on native Win32 install of
>     perl/apache/mod_perl. but apache goes into some sort of loop, eating
>     memory and a kill is required, but this is random and only after
>     some load testing.
> 
> -- 
> Jason Czerak (Jason.Czerak@minn.PPDi.com <mailto:Jason.Czerak@minn.PPDi.com>)
> 
> 
> 
> 
> 
> 
>     ______________________________________________________________________
>     This email transmission and any documents, files or previous email
>     messages attached to it may contain information that is confidential or
>     legally privileged. If you are not the intended recipient or a person
>     responsible for delivering this transmission to the intended recipient,
>     you are hereby notified that you must not read this transmission and
>     that any disclosure, copying, printing, distribution or use of this
>     transmission is strictly prohibited. If you have received this transmission
>     in error, please immediately notify the sender by telephone or return email
>     and delete the original transmission and its attachments without reading
>     or saving in any manner.
> 
> 
> --
> Jeff Pang
> NetEase AntiSpam Team
> http://corp.netease.com
> 




Mime
View raw message