perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Wiles <fr...@wiles.org>
Subject Re: errors in module.t & others when installing mod_perl
Date Fri, 03 Feb 2006 22:41:15 GMT
On Fri, 03 Feb 2006 14:35:05 -0800
Bennett Haselton <bennett@peacefire.org> wrote:

> I also tried doing:
> rpm -e mod_perl
> and I got:
> error: Failed dependencies:
>          mod_perl is needed by (installed)
> psa-7.5.0-fc2.build75041208.20
> 
> I am completely stuck again, sorry!

  Well you're trying to run this in an environment with Plesk, that
  is going to cause you untold amount of headaches. Control panels
  like Plesk, cPanel, etc. aren't built to support more advanced
  setups.  

  Here are some suggestions: 

  1) If you aren't using Plesk then uninstall it with: 

     rpm -e psa
     rpm -e mod_perl 

  2) If you are wanting to use it for some sites, but not your mod_perl
     ones you can install Apache into another location from source 
     and compile mod_perl against that. 

 ---------------------------------
   Frank Wiles <frank@wiles.org>
   http://www.wiles.org
 ---------------------------------


Mime
View raw message