perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Galbreath" <Galbrea...@gao.gov>
Subject Re: Mod_perl using wrong version of perl
Date Tue, 31 Jan 2006 22:05:58 GMT
I had the same problem when I installed 5.8.7 over 5.8.6.  I had to do a
 
   find / -iname "*perl*
 
and because I'm not smart enough to know all the shit on my machine that uses perl nor was
I inclined to hunt down every config file, instead of deleting all the old perl I created
symbolic links pointing to the "same" files in the new perl.
 
Also, do a
 
   ./configure --help
 
on the mod_perl install and you can see that you can direct the C compiler to libraries other
than the defaults.
 
mark

>>> Steven Bush <steven@knowmad.com> 31-Jan-06 15:21:21 PM >>>

I just installed a new version of perl (5.8.7) on one of my servers. 
After I had a complete install w/o any trouble, I re-installed mod_perl 
(2.0.2) so that it would be using my newer version of perl. It is not. 
It is still using the old version (5.8.3). I have recompiled perl and 
mod_perl in an attempt to fix this, but it is still using 5.8.3. Both 
perl and mod_perl were made in directories that had never been used for 
that before, and I make clean just in case anyways, so there should be 
no pollution. Please help me get this working. Thanks in advance.

~Steven

Output from mp2bug:

-------------8<---------- Start Bug Report ------------8<----------
1. Problem Description:

  [DESCRIBE THE PROBLEM HERE]

2. Used Components and their Configuration:

*** mod_perl version 2.000002

*** using /home/quicktel/tmp/mod_perl-2.0.2/lib/Apache2/BuildConfig.pm

*** Makefile.PL options:
  MP_APR_LIB     => aprext
  MP_APXS        => /usr/local/apache2_docs/bin/apxs
  MP_COMPAT_1X   => 1
  MP_GENERATE_XS => 1
  MP_LIBNAME     => mod_perl
  MP_USE_DSO     => 1


*** /usr/local/apache2_docs/bin/httpd -V
Server version: Apache/2.0.55
Server built:   Jan 27 2006 16:05:52
Server's Module Magic Number: 20020903:11
Architecture:   32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/usr/local/apache2_docs"
-D SUEXEC_BIN="/usr/local/apache2_docs/bin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"

*** /usr/bin/ldd /usr/local/apache2_docs/bin/httpd
    libz.so.1 => /usr/lib/libz.so.1 (0x4001d000)
    libaprutil-0.so.0 => /usr/local/apache2_docs/lib/libaprutil-0.so.0 
(0x4002f000)
    libgdbm.so.3 => /usr/lib/libgdbm.so.3 (0x40045000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x4004b000)
    libapr-0.so.0 => /usr/local/apache2_docs/lib/libapr-0.so.0 (0x4006b000)
    librt.so.1 => /lib/librt.so.1 (0x4008c000)
    libm.so.6 => /lib/libm.so.6 (0x4009f000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x400c1000)
    libnsl.so.1 => /lib/libnsl.so.1 (0x400ef000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x40104000)
    libdl.so.2 => /lib/libdl.so.2 (0x40155000)
    libc.so.6 => /lib/libc.so.6 (0x40158000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)


*** (apr|apu)-config linking info

-L/usr/local/apache2_docs/lib -laprutil-0 -lgdbm -lexpat
-L/usr/local/apache2_docs/lib -lapr-0 -lrt -lm -lcrypt -lnsl  -lpthread 
-ldl



*** /usr/local/bin/perl -V
Summary of my perl5 (revision 5 version 8 subversion 7) configuration:
  Platform:
    osname=linux, osvers=2.4.25, archname=i686-linux
    uname='linux webserv 2.4.25 #1 smp tue apr 6 12:23:14 edt 2004 i686 
gnulinux '
    config_args='-de'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef 
usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -I/usr/local/include 
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fno-strict-aliasing -pipe -I/usr/local/include'
    ccversion='', gccversion='3.3.5 (Debian 1:3.3.5-13)', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', 
lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/libc-2.3.2.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.3.2'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'


Characteristics of this binary (from libperl):
  Compile-time options: USE_LARGE_FILES
  Built under linux
  Compiled at Jan 31 2006 13:13:36
  %ENV:
    PERL5LIB="/home/quicktel/QT-Web/perl5/5.8.3"
    PERL_LWP_USE_HTTP_10="1"
  @INC:
    /home/quicktel/QT-Web/perl5/5.8.3
    /usr/local/lib/perl5/5.8.7/i686-linux
    /usr/local/lib/perl5/5.8.7
    /usr/local/lib/perl5/site_perl/5.8.7/i686-linux
    /usr/local/lib/perl5/site_perl/5.8.7
    /usr/local/lib/perl5/site_perl/5.8.3/i686-linux
    /usr/local/lib/perl5/site_perl/5.8.3
    /usr/local/lib/perl5/site_perl
    .

*** Packages of interest status:

Apache2            : -
Apache2::Request   : -
CGI                : 3.10
ExtUtils::MakeMaker: 6.17
LWP                : 5.76
mod_perl           : -
mod_perl2          : 2.000002, 2.000002


3. This is the core dump trace: (if you get a core dump):

  [CORE TRACE COMES HERE]

This report was generated by /usr/local/bin/mp2bug on Tue Jan 31 
20:09:15 2006 GMT.

-------------8<---------- End Bug Report --------------8<----------

Note: Complete the rest of the details and post this bug report to
modperl <at> perl.apache.org. To subscribe to the list send an empty
email to modperl-subscribe@perl.apache.org.






Mime
View raw message