perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barry Hoggard <tristanme...@gmail.com>
Subject [mp2] "Expected token not present" error in logs
Date Sun, 08 Jan 2006 16:18:10 GMT
1. Problem Description:

Once in a while (5 times in one day, then nothing for weeks), we get  
server errors and the only thing that appears in the logs is:

[Sat Jan 07 14:44:43 2006] [error] [client 127.0.0.1] Expected token  
not present, referer: http://www.xxxxxxx.com/

where the referrer is our public static apache server and the MP2  
server is running bound to localhost.

Googling didn't show up much other than a reference to libapreq2.   
How should I fix this?  Also, I followed the instructions for  
upgrading to MP2 after the API  change, but I still see the mod_perl  
1.99 stuff in there.  Does that mean I missed something?



2. Used Components and their Configuration:

*** mod_perl version 2.000002

*** using /opt/perl-5.8.6/lib/site_perl/5.8.6/i686-linux/Apache2/ 
BuildConfig.pm

*** Makefile.PL options:
   MP_APR_LIB     => aprext
   MP_AP_PREFIX   => /opt/apache2
   MP_COMPAT_1X   => 1
   MP_GENERATE_XS => 1
   MP_LIBNAME     => mod_perl
   MP_USE_DSO     => 1


*** The httpd binary was not found


*** (apr|apu)-config linking info

-L/opt/apache2/lib -laprutil-0 -lgdbm -ldb-4.2 -lexpat
-L/opt/apache2/lib -lapr-0 -lrt -lm -lcrypt -lnsl  -lpthread -ldl



*** /opt/perl-5.8.6/bin/perl -V
Summary of my perl5 (revision 5 version 8 subversion 6) configuration:
   Platform:
     osname=linux, osvers=2.4.21-27.0.1.el, archname=i686-linux
     uname='linux dev.manifestinvesting.com 2.4.21-27.0.1.el #1 mon  
dec 20 18:47:51 est 2004 i686 athlon i386 gnulinux '
     config_args='-Dprefix=/opt/perl-5.8.6 -des'
     hint=recommended, useposix=true, d_sigaction=define
     usethreads=undef use5005threads=undef useithreads=undef  
usemultiplicity=undef
     useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
     use64bitint=undef use64bitall=undef uselongdouble=undef
     usemymalloc=n, bincompat5005=undef
   Compiler:
     cc='cc', ccflags ='-fno-strict-aliasing -pipe -I/usr/local/ 
include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm',
     optimize='-O2',
     cppflags='-fno-strict-aliasing -pipe -I/usr/local/include -I/usr/ 
include/gdbm'
     ccversion='', gccversion='3.2.3 20030502 (Red Hat Linux  
3.2.3-49)', gccosandvers=''
     intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
     d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
     ivtype='long', ivsize=4, nvtype='double', nvsize=8,  
Off_t='off_t', lseeksize=8
     alignbytes=4, prototype=define
   Linker and Libraries:
     ld='cc', ldflags =' -L/usr/local/lib'
     libpth=/usr/local/lib /lib /usr/lib
     libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc
     perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
     libc=/lib/libc-2.3.2.so, so=so, useshrplib=false, libperl=libperl.a
     gnulibc_version='2.3.2'
   Dynamic Linking:
     dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
     cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'


Characteristics of this binary (from libperl):
   Compile-time options: USE_LARGE_FILES
   Built under linux
   Compiled at Feb  2 2005 15:22:17
   %ENV:
     PERL_LWP_USE_HTTP_10="1"
   @INC:
     /opt/perl-5.8.6/lib/5.8.6/i686-linux
     /opt/perl-5.8.6/lib/5.8.6
     /opt/perl-5.8.6/lib/site_perl/5.8.6/i686-linux
     /opt/perl-5.8.6/lib/site_perl/5.8.6
     /opt/perl-5.8.6/lib/site_perl
     .

*** Packages of interest status:

Apache2            : -
Apache2::Request   : 2.06-dev
CGI                : 3.15
ExtUtils::MakeMaker: 6.17
LWP                : 5.803
mod_perl           : 1.999021
mod_perl2          : 2.000002




--
Barry Hoggard
Tristan Media LLC
w: www.tristanmedia.com
yahoo/aim: hoggardb


Mime
View raw message