perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Schilli...@perlmeister.com>
Subject Apache core dumps on loading mod_perl
Date Mon, 09 Jan 2006 02:13:24 GMT
Hi all,

using perl-5.8.5, apache 1.3.x and mod_perl 1.29, I'm getting a core dump
when libperl.so gets loaded via LoadModule perl_module path/libperl.so.
Does the following gdb stack trace ring a bell with anyone?

  #0  0x203eeba0 in .cerror () from /usr/lib/libc.so.4
  #1  0x00000006 in ?? ()
  #2  0x402c7413 in ?? ()
  #3  0x9fbfcea0 in ?? ()
  #4  0x2062e7aa in ioctl () from /usr/lib/libc_r.so.4
  #5  0x203ee5bb in tcgetattr () from /usr/lib/libc.so.4
  #6  0x203ecb82 in isatty () from /usr/lib/libc.so.4
  #7  0x203ec23e in __smakebuf () from /usr/lib/libc.so.4
  #8  0x203dc50f in __srefill () from /usr/lib/libc.so.4
  #9  0x203dc3df in __srget () from /usr/lib/libc.so.4
  #10 0x20390434 in fgetc () from /usr/lib/libc.so.4
  #11 0x205a4312 in PerlIOStdio_read (my_perl=0x107000, f=0xcc710,
      vbuf=0x9fbfd03b, count=1) at perlio.c:2996
  #12 0x205a247e in Perl_PerlIO_read (my_perl=0x107000, f=0xcc710,
      vbuf=0x9fbfd03b, count=1) at perlio.c:1564
  #13 0x205a65fe in PerlIO_getc (f=0xcc710) at perlio.c:4771
  #14 0x2054d46c in Perl_sv_gets (my_perl=0x107000, sv=0x1228d8, fp=0xcc710,
      append=0) at sv.c:6341
  #15 0x204ecf2c in S_filter_gets (my_perl=0x107000, sv=0x1228d8, fp=0xcc710,
      append=0) at toke.c:2109
  #16 0x204ee220 in Perl_yylex (my_perl=0x107000) at toke.c:2507
  #17 0x20502987 in Perl_yyparse (my_perl=0x107000) at perly.c:1470
  #18 0x204df141 in S_parse_body (my_perl=0x107000, env=0x0,
      xsinit=0x20487210 <mod_perl_xs_init>) at perl.c:1768
  #19 0x204de0b4 in perl_parse (my_perl=0x107000,
      xsinit=0x20487210 <mod_perl_xs_init>, argc=2, argv=0x9fbff8a0, env=0x0)
      at perl.c:1272
  #20 0x2048780c in perl_startup (s=0x9ccc8, p=0x9cca0) at mod_perl.c:702
  #21 0x204871d3 in perl_module_init (s=0x9ccc8, p=0x9cca0) at mod_perl.c:569
  #22 0x0004cd73 in ap_init_modules (p=0x9cca0, s=0x9ccc8) at
http_config.c:1726
  #23 0x00056c79 in main (argc=4, argv=0x9fbff9e0) at http_main.c:6459

Any help appreciated.

-- Mike

Mike Schilli
m@perlmeister.com

Mime
View raw message