perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: MIME::Lite / mod_perl2 segfault
Date Thu, 22 Dec 2005 05:02:26 GMT
On Wed, 21 Dec 2005, Peter Mogensen wrote:

> Frank Wiles wrote:
>>> My system is Debian Sarge, kernel 2.6.12.5 (custom compiled)
>>> The rest is standard Sarge:
>>> ii  apache2        2.0.54-5
>>> ii  apache2-common 2.0.54-5
>>> ii  apache2-mpm-pr 2.0.54-5
>>> ii  apache2-utils  2.0.54-5
>>> ii  libapache2-mod 1.999.21-1
> ...
>>   You're going to most likely want to install a newer version of
>>   mod_perl than you have.  Right now you're running one of the release
>>   candidates, but not the actual release.  Upgrading may make this
>>   problem go away.
>
> Yes. But the above version is what ships with Sarge (unfortunately) due
> to the API change, and I would need a very good reason to upgrade to the
> new API at present. So if there was a simple explanation, which I could
> solve by a slight modifictation to one of the Sarge packages, that would
> be best.

FWIW, I tried out a simple hello-world content handler that
had a
    use MIME::Lite;
in it on Win32, perl-5.8.7, MIME-Lite version 3.01, and
mod_perl 2.0.2, and there were no problems.

-- 
best regards,
randy kobes

Mime
View raw message