perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John ORourke <john-modp...@o-rourke.org>
Subject Re: MIME::Lite / mod_perl2 segfault
Date Thu, 22 Dec 2005 07:32:48 GMT
Dunno if this'll help but a couple of points:

1 - why use <Location ~ "^/mp/$"> instead of <Location /mp> in httpd.conf?
2 - I successfully upgraded Apache and mod_perl without too much 
trouble, there were many bug fixes between 1.99* and 2.0.1.  Well worth it.
3 - I'm "use"ing MIME::Lite 3.01 on mod_perl 2.0.1, httpd 2.0.51, Perl 
5.8.3 (Fedora Core 2), no problems.

>>
>> Yes. But the above version is what ships with Sarge (unfortunately) due
>> to the API change, and I would need a very good reason to upgrade to the
>> new API at present. So if there was a simple explanation, which I could
>> solve by a slight modifictation to one of the Sarge packages, that would
>> be best.
>
>
> FWIW, I tried out a simple hello-world content handler that
> had a
>    use MIME::Lite;
> in it on Win32, perl-5.8.7, MIME-Lite version 3.01, and
> mod_perl 2.0.2, and there were no problems.
>


Mime
View raw message