perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damyan Ivanov <diva...@creditreform.bg>
Subject Re: *nix distro compatibility (was Re: survey)
Date Fri, 16 Sep 2005 07:27:11 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jeff wrote:
>> That's not entirely true.  Debian Sarge (stable) and Ubuntu Hoary both
>> include packages for Apache 1.3.33 and Apache2 (2.0.54?).  Sarge has a
>> mod_perl2 package but it's based on a late 2.0RC, though it is
>> post-rename, IIRC.  
> 
> Actually, the Debian Stable aka Sarge has 1.999.21-1 which is
> PRE-rename, and effectively useless, and libapreq2 - never made it into
> Debian Stable at all.
> 
> The good news is that with the three year release cycle having just
> started again, we might have a stable mod_perl2 by end 2008! :o
> 
> I hear rumours that backports.org might do something in the near future
> for libapache2-mod-perl, but haven't heard anything about libapreq2.
> 
> At the moment, for Debian Stable, as Perrin harkens, roll-your-own time!

It's worth noting, that Debian Unstable aka sid has mod_perl 2.0.1,
apache 2.0.54 and libapreq2 2.06-dev, all of which run fairly well.
Docs are sparse, however (see bug #285588).

Packages from sid are seldom installable on stable, though.


dam
- --
Damyan Ivanov          0x9725F63B          Creditreform Bulgaria
divanov@creditreform.bg              http://www.creditreform.bg/
phone: +359(2)928-2611, 929-3993            fax: +359(2)920-0994
mob. +359(88)856-6067  ICQ 3028500  dam@jabber.minus273.org/Gaim
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDKnPOHqjlqpcl9jsRAslmAKCL+Z42ZP4g8VAWhDXJH8XpT4o3vACgsJ+Q
R8IppFZw3na5u7uRADWxV7I=
=quPq
-----END PGP SIGNATURE-----

Mime
View raw message