perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sive Lindmark <s...@capestream.se>
Subject Is there a bug in Apache 2, ModPerl 2 or APR for data larger than 64k?
Date Thu, 04 Aug 2005 13:11:25 GMT
Hi!

Have used mod_perl 2.0 and newer  for a while and it have worked very 
well on Mac OS X and Free BSD servers. Now on a Xserve with Mac Os 10.4 
the following happens. Requesting a web page with little contents works 
okey but an bigger contents the loading always stops in the middle with 
the following error message in error_log.

(35)Resource temporarily unavailable: core_output_filter: writing data 
to the network

The error is coming in different places in the code but always about 
half the page so searching the web I found some stuff. "There is a bug 
in APR 0.9.6 that is present when it is running on Tiger, and shows up 
when you attempt to check out a file larger than 64K." 
http://subversion.tigris.org/faq.html#tiger-apr-0.9.6'

If this the cause of our problem I sought that by installing the latest 
versions of mod_perl and apache2 (SERVER_SOFTWARE = Apache/2.1.6 (Unix) 
mod_perl/2.0.2-dev Perl/v5.8.6) could fix this.....  but no

I also tried setting a environment variable  before configuring Apache 
and modPerl2 suggested as fix above.
"Currently, the best solution is to rebuild Apache from their 
respective sources, setting the following environment variable before 
running configure for Apache in Bourne shell syntax, like this: 
ac_cv_func_poll=no; export ac_cv_func_poll     "

Now I have no more ideas about what to do....  any suggestions?
What APR version is there in latest mod_perl?   Can the bug above still 
be there or ...

Thanks in forehand!
Sive









Mime
View raw message