perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Schindl <tomAtLi...@gmx.at>
Subject Re: Apache, Mod_Perl Upgrade
Date Wed, 24 Aug 2005 08:57:51 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

[...]
> /opt/perl/bin/perl Makefile.PL MP_APXS=/opt/httpd/bin/apxs
> Reading Makefile.PL args from @ARGV
>   MP_APXS = /opt/httpd/bin/apxs
> no conflicting prior mod_perl version found - good.
> [  error] '/opt/httpd/bin/apxs -q INCLUDEDIR' failed:
> [  error] Can't locate strict.pm in @INC (@INC contains:
> /usr/local/lib/perl5/5.8.7/i686-linux /usr/local/lib/perl5/5.8.7
> /usr/local/lib/perl5/site_perl/5.8.7/i686-linux
> /usr/local/lib/perl5/site_perl/5.8.7 /usr/local/lib/perl5/site_perl .)
> at /opt/httpd/bin/apxs line 19.
> BEGIN failed--compilation aborted at /opt/httpd/bin/apxs line 19.
> [  error] Unable to determine server version, aborting.
> [  error] Invalid MP_APXS specified?


This is completely the wrong perl as you can see from your
"/usr/local/lib/perl5/....".

> I have installed perl and apache as described above. Include should be
> /opt/perl? Any ideas? Thanks in advance.

Have you tried to install mp2 using this directory before then I would
suggest that you remove it and unzip mp2.tar.gz once again maybe there's
something left from your last installation try?

> Jon

Tom


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Using GnuPG with Mandriva - http://enigmail.mozdev.org

iD8DBQFDDDaPkVPeOFLgZFIRArO9AKCRaU7dxiTdxQgVzWqQsvRbs9VA6QCfTLwi
vd77o0QQqpU6J7dI9imZx7c=
=E8Yd
-----END PGP SIGNATURE-----

Mime
View raw message