perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bengt-Arne Fjellner" <Bengt-Arne.Fjell...@ltu.se>
Subject Re: [mp2.0.1] [bug] [Makefile.PL] again,now with patch
Date Sat, 23 Jul 2005 11:02:34 GMT


Background my apche is not installed exactly as standard.
because of that my moduls should be /usr/lib/apache which apxs nows. mod_perl.so
gets installed in the right place but the text that tells where it is is wrong

perl Makefile.PL MP_APXS=/usr/sbin/apxs  ends with:
<snip>
[warning] mod_perl dso library will be built as mod_perl.so
[warning] You'll need to add the following to httpd.conf:
[warning] baf LoadModule perl_module modules/mod_perl.so

but:
root@xxxx ~/mod_perl-2.0.1# apxs -q  LIBEXECDIR
/usr/lib/apache

which is where it gets installed.
suggested patch: (no guarantees at all)

better patch than the previous:
--- Makefile.PL.org     2005-07-23 10:47:42.000000000 +0200
+++ Makefile.PL 2005-07-23 13:00:15.000000000 +0200
@@ -389,10 +389,11 @@
     }

     if ($build->is_dynamic) {
+       my $dir=$build->apxs(-q => 'LIBEXECDIR');
+       $dir='modules' unless $dir;
         warning "You'll need to add the following to httpd.conf:",
-                " LoadModule perl_module modules/$build->{MODPERL_LIB_DSO}\n";
+                "LoadModule perl_module $dir/$build->{MODPERL_LIB_DSO}\n";
     }
-
     $build->save;
 }


-- 
cheers
Bengt-Arne Fjellner
LuleƄ university of technology
SkellefteƄ Sweden




-- 
Bengt-Arne Fjellner
0910-58 53 69



Mime
View raw message