perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [MP2] Bug report - errors when compiling with MP_DEBUG flag
Date Sat, 11 Jun 2005 14:32:48 GMT
William McKee wrote:
[...]
>>If you look at the linking command that you've pasted in the original
>>report it had:
>>
>>  /usr/local/src/httpd-2.0.54/srclib/apr/libapr-0.la
>>
>>which is the one that you need to check.
> 
> 
> Actually, I had taken a look in that file but there's nothing being
> defined in there.

certainly, it's a C define, which can't be seen from .la. I was just 
saying that .so has nothing to do with it. It's .la that's linked.

>>>I then grepped by mod_perl and httpd source directories for header files
>>>which defined APR_HAS_THREADS. I changed srclib/apr/include/apr.h and
>>>srclib/apr/include/apr.hnw then reconfigured mod_perl but it still
>>>failed.
>>
>>Please find all occurences of apr.h and check the value of APR_HAS_THREADS.
> 
> 
> OK, I ran the following command and have found the file which set that
> value to 1:
> 
>   find / -name *apr.h -print -exec grep APR_HAS_THREADS {} \;
> 
> After setting it to 0, I reran the build process. That appears to be
> working now but I'm still having some problems with tests failing :(.
> The important thing is the debug flags should be on for this build. I
> can live with some of the tests failing.

I'd suggest to nuke all occurences of Apache and libapr, clean your system 
completely and then start from scratch.


-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message