perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Duran" <ste...@nmmcc.com>
Subject RE: mod_perl2: cannot load Apache::AuthCookie for Apache 2.0
Date Sat, 11 Jun 2005 01:46:53 GMT

  Thanks, Fred.  It worked.

--
Steve Duran
Web Administrator

-----Original Message-----
From: Fred Moyer [mailto:fred@taperfriendlymusic.org] 
Sent: Friday, June 10, 2005 2:40 PM
To: Steve Duran
Cc: modperl@perl.apache.org
Subject: Re: mod_perl2: cannot load Apache::AuthCookie for Apache 2.0


> PerlModule Apache2::compat
> PerlModule mod_perl2
> PerlModule Apache::AuthCookie

Use this line instead for use with mod_perl2 -
'PerlModule Apache2::AuthCookie'

> 
>   The first error that I got was that it could not find the 
> Apache::Util module.  The only place I could find this was in the 
> mod_perl download, and this will only install if it can see the Apache 
> 1.3 source.  So I downloaded and compiled apache_1.3.33, then 
> installed mod_perl-1.29.  This is the error that I'm getting now.
> 
> [Thu Jun 09 19:09:37 2005] [error] Can't locate object method "boot" 
> via package "mod_perl" at 
> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Apache/Util.pm 
> line 20.\nCompilation failed in require at 
> /usr/lib/perl5/site_perl/5.8.0/Apache/AuthCookie.pm line 9.\nBEGIN 
> failed--compilation aborted at 
> /usr/lib/perl5/site_perl/5.8.0/Apache/AuthCookie.pm line 
> 9.\nCompilation failed in require at (eval 4) line 3.\n
> 
>   How can I get this to work?
> 
>   Thanks,
> 
>   Steve


Mime
View raw message