perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Hilbig <thil...@yahoo.com>
Subject Re: Help (Desperate) - Install Bundle::Apache2 catastrophic
Date Sun, 12 Jun 2005 15:52:37 GMT
Sorry, httpd is 2.0.52 and not 2.0.54 (sorry, panic).

My whole site is Perl CGI based using ModPerl2 for
performance, using Perl CGI library for requests and
not the pure Apache requests.  It's always worked up
until loading the Bundle::Apache2 package.  I wanted
to load the Apache2 API for some ModPerl handler
writing.

Most common CGI errors are:

 Can't locate object method "register_cleanup" via
package "Apache::RequestRec" at
/usr/lib/perl5/5.8.5/CGI.pm

 Undefined subroutine
&ModPerl::ROOT::ModPerl::Registry::
 


--- Thomas Hilbig <thilbig@yahoo.com> wrote:

> I just installed the perl Bundle::Apache2 on a
> working
> 2.0.54 environment.  My thought this was using a
> separate namespace and I could migrate the MP2 code
> over to the Apache2 API from Apache API.  I have
> always been on Apache 2 and MP2, but using the API's
> that came with it on a Fedora Core 3 install.
> 
> Wrong!  Now, all my CGI scripts are dead.
> 
> I need to quickly either restore the original
> modules
> or make the changes necessary to get the old stuff
> working under Apache2.
> 
> Help!
> 
> 
> 		
> __________________________________ 
> Discover Yahoo! 
> Find restaurants, movies, travel and more fun for
> the weekend. Check it out! 
> http://discover.yahoo.com/weekend.html 
> 
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

Mime
View raw message