perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gokul P. Nair" <gpnai...@yahoo.com>
Subject mod_perl2 make test errors - Apache2::Const
Date Mon, 06 Jun 2005 19:03:07 GMT
I'm tyring to compile and install mod_perl 2.0 as a
dso on Apache 2.0.52 but it complains about not being
able to load Apache2::Const module. This is the error
i get when i run make test:

Can't load
'/usr/local/src/mod_perl-2.0.0/blib/arch/auto/Apache2/Const/Const.so'
for module Apache2::Const:
/usr/local/src/mod_perl-2.0.0/blib/arch/auto/Apache2/Const/Const.so:
undefined symbol: PL_markstack_ptr at
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm
line 230.\n at
/usr/local/src/mod_perl-2.0.0/t/conf/modperl_extra.pl
line 32\nCompilation failed in require at
/usr/local/src/mod_perl-2.0.0/t/conf/modperl_extra.pl
line 32.\nBEGIN failed--compilation aborted at
/usr/local/src/mod_perl-2.0.0/t/conf/modperl_extra.pl
line 32.\nCompilation failed in require at
/usr/local/src/mod_perl-2.0.0/t/conf/modperl_startup.pl
line 17.\n\t...propagated at
/usr/local/src/mod_perl-2.0.0/t/conf/modperl_startup.pl
line 18.\nBEGIN failed--compilation aborted at
/usr/local/src/mod_perl-2.0.0/t/conf/modperl_startup.pl
line 20.\nCompilation failed in require at (eval 2)
line 1.\n

I had mod_perl 1.999.20 running on it prior to this
and so obviously my next step was to try and remove it
as i thought it might be interfering with the new
installation in some way. I did so successfully using:
find /usr/lib/perl5 -name 'Apache2*' -exec rm -rf {}
\;
as specified in the mod_perl 2.0 rename document.

Tried make test and got the same errors again. 
Anybody have any ideas as to what might be causing
this?

Thanks for all your help in advance.

Gokul






		
__________________________________ 
Discover Yahoo! 
Get on-the-go sports scores, stock quotes, news and more. Check it out! 
http://discover.yahoo.com/mobile.html

Mime
View raw message