perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: mos_perl2 on Windows
Date Mon, 23 May 2005 17:49:58 GMT
On Mon, 23 May 2005, Robert wrote:

> I just installed it via PPM (for ActiveStates 5.8.6.811).
> I had my site working under Apache1/CGI without problem.
>
> I upgraded to Apache2/mod_perl and I configured my site conf like so (per
> the docs):
>
> alias /reports "C:\path\to\reports"
>
> PerlModule ModPerl::PerlRun
>
> <Directory "path\to\reports">
>       SetHandler perl-script
>       PerlResponseHandler ModPerl::PerlRun
>       PerlOptions +ParseHeaders
>       Options +ExecCGI
> </Directory>
>
> My httpd.conf looks like:
>
> #
> # MOD_PERL 2.0
> #
> LoadFile "C:/Perl/bin/perl58.dll"
> LoadModule perl_module modules/mod_perl.so
> #PerlRequire "C:/Apache2/conf/extra.pl"   <--- this errors out on APR.DLL
> even though it is there...Apache won't start unless I comment this out
>
> Apache starts without errors but I get the following error when trying to
> server up the page:
>
> [Mon May 23 11:46:57 2005] [error] [client 10.149.82.49] Attempt to serve
> directory: C:/path/to/reports/

I take it this is for a request of
   http://localhost/reports
You probably do want Apache to refuse; for security reasons,
you wouldn't want a user to get a listing of scripts in
such a directory.

Do requests for
   http://localhost/reports/some_script_that_does_exist
succeed?

-- 
best regards,
randy kobes

Mime
View raw message