perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: RC6 build problems
Date Sat, 14 May 2005 00:06:21 GMT
Malcolm J Harwood wrote:
> I'm attempting to build a static apache/mp RC6, and running into some build 
> issues.
> 
> The config line ends up looking like this:
> 
>  perl Makefile.PL 
> MP_AP_PREFIX=/home/mjh/devel/abs/local/apache-mod_perl//src/httpd-2.0.53 
> MP_USE_STATIC=1 MP_AP_CONFIGURE="--with-mpm=prefork --prefix=/usr 
> --enable-layout=RedHat --datadir=/home/httpd --disable-auth 
> --disable-autoindex --disable-cgi --disable-dir --disable-env --disable-imap 
> --disable-include --disable-negotiation --disable-userdir --enable-deflate 
> --enable-logio --enable-ssl --enable-access --disable-mime" 
> MP_AP_DESTDIR=/home/mjh/devel/abs/local/apache-mod_perl//pkg/
> 
> and results in a line reading:
>  cd "/home/mjh/devel/abs/local/apache-mod_perl/src/httpd-2.0.53" && make 
> DESTDIR=0 10 6 4 3 2 10DESTDIR) install

It comes from Makefile.PL:

ap_install: ap_build
	cd "$build->{MP_AP_PREFIX}" && make DESTDIR=$(DESTDIR) install
EOF

Please apply the attached patch. It should fix the problem.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message