perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: [mp2] modperl2 compile error
Date Mon, 09 May 2005 20:46:10 GMT
Tom Caldwell wrote:
> Stas and Marc,
> 
> So after a week hiatus I was finally able to return to my 
> Perl/ModPerl2/Apache2 woes on my Dell 64bit box running redhat linux.
> 
> When we last left the main saga, I had just rebuilt perl and modperl 
> with the -fPIC flag only to find that the tests for subprocess.t would 
> not work. I tried several suggestions from Stas but nothing worked. Mark 
> suggested recompiling apache as well and that was to be my next step 
> before I was sidelined by other issues.
> 
> When I rebuilt apache today, the modperl tests still failed at 
> subprocess.t even after another modperl rebuild. So I did another 
> reinstall of perl. This time during the configure operation when the 
> script prompted for directories to search for standard libs the defaults 
> were /usr/local/lib /lib /usr/lib (as before). After checking out the 
> original redhat installed version of perl (from rpm vesion 5.8.0), I 
> noticed that it used mostly libs from /lib64 and /usr/lib64. So I 
> overrode the defaults for this question with - /lib /usr/lib /lib64 
> /usr/lib64. Then when I got to the prompt for default libs it had all 
> the ones I needed as the default value which it had failed to do before. 
> I still had to change the link flags from -fpic to -fPIC and replace the 
> default link switches with values I found in the redhat perl, but then 
> all of the tests for perl and modperl passed.
> 
> I did not even have to rebuild apache after that.

Great. Tom any chance you could write a simple step by step document of 
what you have done, including commands for other users who will hit the 
same problem? we can add it to the troubleshooting docs. Thanks!

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message