perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: Apache-DBI
Date Tue, 19 Apr 2005 06:16:17 GMT
On Tue, 19 Apr 2005, Octavian Rasnita wrote:

> From: "Randy Kobes" <randy@theoryx5.uwinnipeg.ca>
> > That's potentially true in general, but Apache-DBI is a pure
> > Perl module, so it doesn't need a C compiler to build.
> > If you want to play around with it, we have a ppm package
> > of Apache-DBI at http://theoryx5.uwinnipeg.ca/ppms/ - you
> > can install it, and then try patching the .pm files
> > (either with a "patch" utility for Windows, or just
> > manually).
>
> Ok, I already have downloaded that version of Apache::DBI
> from TheoryX. I will try to patch it manually because I
> don't have a "patch" utility for Windows. I guess I will
> need just to replace some modules calls like that mod_perl
> rc5 announcement says.

That's true; if you need a patch utility, try the Perl Power
tools: http://ppt.perl.org/.

> Or... if you say that it is a pure perl module, I can just
> build it using nmake.

Yes, nmake would be needed for Win32 ActivePerl in building
a package from the CPAN sources. However, the Apache-DBI ppm
package is at the same version as the package on CPAN, so
either way, you'll have to try some patches.

-- 
best regards,
randy

Mime
View raw message