perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Octavian Rasnita" <orasn...@fcc.ro>
Subject Problem installing mod_perl (because of CGI?)
Date Wed, 06 Apr 2005 16:52:02 GMT
Hi,

Here is the error I get after "make test" phase of mod_perl installation:

[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/local/bin/perl
/home/teddy/mod_perl/mod_perl-2.0.0-RC4
APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT= APACHE_TEST_USER=
APACHE
/usr/local/bin/perl -Iblib/arch -Iblib/lib \
t/TEST -bugreport -verbose=0
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/local/bin/perl
/home/teddy/mod_perl/mod_perl-2.0.0-RC4
/usr/local/site/bin/httpd  -d /home/teddy/mod_perl/mod_perl-2.0.0-RC4/t -f
/home
onf -D APACHE2 -D PERL_USEITHREADS
using Apache/2.0.53 (prefork MPM)
waiting 120 seconds for server to start: .Syntax error on line 861 of
/home/tedd
Invalid command 'SetEnv', perhaps mis-spelled or defined by a module not
include
[  error]
server has died with status 255 (t/logs/error_log wasn't created, start the
serv
make: *** [run_tests] Error 143
[teddy@dual mod_perl-2.0.0-RC4]$


Well, the error "Invalid command 'SetEnv', perhaps mis-spelled or defined by
a module not included" makes me think that the problem is that Apache
doesn't have the module CGI installed.
(I know that Apache doesn't have the module CGI installed because I have
tried ./httpd -l and mod_cgi.c doesn't appear in that list of compiled
modules and I cannot find that module in the "modules" directory).

Is it possible to install mod_perl if mod_cgi is not installed?

If yes, why do I get that error?
If it is not possible, please tell me if there is a way of installing the
CGI module without re-installing Apache.

I have 2 Apache servers installed on the same computer, and the server I
want to install mod_perl for, is Apache 2.0.53.

Thank you much.

Teddy


Mime
View raw message