perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: make test fails on HPUX/IA64: Can't locate TestFilter/both_str_req_add.pm
Date Tue, 07 Dec 2004 17:16:35 GMT
Gisle Aas wrote:
> Stas Bekman <stas@stason.org> writes:
> 
> 
>>>Did not think about that.  Yes, the default limit is 60 opened files
>>>on this machine.  I ran 'ulimit -n 1024' and then 'make test' again.
>>
>>Great.
>>
>>I wish we could somehow automate this diagnostics to save the wasted
>>time for the report-response email cycle. As you can see it's not the
>>first time we get it reported. Ideas?
> 
> 
> Can't t/TEST check the output of 'ulimit -n' and verify that it is
> high enough?  

Good idea, Gisle. But will it work everywhere where perl runs?

> Alternatively try the BSD::Resource module?

So does it mean that 'ulimit -n' may not work?

> For our mail filtering product (PureMessage) we also had problems with
> reports caused by this limit and we fixed it by embedding this code in
> the server core:
> 
>         if (getrlimit(RLIMIT_NOFILE, &rlim) == 0
>             && rlim.rlim_cur != RLIM_INFINITY
>             && rlim.rlim_cur < rlim.rlim_max)
>         {
>             rlim.rlim_cur = rlim.rlim_max;
>             if (setrlimit(RLIMIT_NOFILE, &rlim) != 0) {
>                 warn("Can't max RLIMIT_NOFILE limit: $!");
>             }
>         }
> 
> This tries to move the soft limit for open files as high as it can go.

nice, but requires BSD::Resource which is not available on all platforms I 
believe. But certainly worth a try.

>>>t/apr-ext/base64........................Can't load
>>
>>'/home/gisle/mod_perl-1.99_17/blib/arch/auto/APR/APR.so' for module APR:
>>Exec format error at
>>/home/gisle/5.8.6/lib/perl5/5.8.6/IA64.ARCHREV_0/DynaLoader.pm line 230.
>>
>>>at /home/gisle/mod_perl-1.99_17/blib/lib/APR/Base64.pm line 23
>>
>>Well, I hope you can tell us what is the problem. I'm not familiar
>>with HPUX/IA64. May be take a look at the make's log and it'll give
>>you the needed information to tell?
> 
> 
> I think this might be caused by compiling Apache itself with gcc while
> perl and mod_perl was compiled with HP's cc.  I'll investigate
> further and report what I find.

That certainly could be the problem.


-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message