perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: make test fails on HPUX/IA64: Can't locate TestFilter/both_str_req_add.pm
Date Tue, 07 Dec 2004 16:03:39 GMT
Gisle Aas wrote:
> 1. Problem Description:
> 
> I just unpacked httpd-2.0.52 and mod_perl-1.99_17 and tried to build
> them with ActivePerl without any extra configuration, but 'make test'
> for mod_perl fails like this:

I think the only time someone has tried HPUX it ended up with this entry:

HPUX11i     DSO
                 PA-RISC2.0-thread-multi-LP64
                 hp-ux loire b.11.11 u 9000800 1756907651 unlimited-user 
license
                 Cannot load .../modules/mod_perl.so into server: Error 0
                 http://marc.theaimsgroup.com/?t=108325310800002&r=1&w=2
                 Bill Rowe gives some hints here
 
http://marc.theaimsgroup.com/?l=apache-modperl&m=108334017416318&w=2
                 Static works OK!

Good to hear that the dynamic build is now starting.

> $ make test

> [Tue Dec 07 04:05:24 2004] [error] Can't locate
> TestFilter/both_str_req_add.pm in @INC (@INC contains:
[...]
> /home/gisle/mod_perl-1.99_17/t/filter

I think you hit the open filehandles limit (mp2 test suite opens a lot of 
those)
http://perl.apache.org/docs/2.0/user/troubleshooting/troubleshooting.html#Can_t_locate_F_TestFilter_in_str_consume_pm__in_C__INC____
since the file 
/home/gisle/mod_perl-1.99_17/t/filter/TestFilter/both_str_req_add.pm is 
there, right?

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message