perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: the scripts under mod_perl are running as mod_cgi
Date Thu, 02 Dec 2004 05:09:37 GMT
SHAHNAWAZ OSMAN wrote:
> Hi Stas,
> 
> 
> Thank you for your speedy response. Now, when I try to
> run the script 
> (http://www.mydoamin.com/perl/test.pl) I get a "404 -
> file not found page" 
> and get the following message in the error log.
> 
> 	"/usr/local/httpd_perl/cgi-bin/test.pl not found or
> unable to stat"
> 	
> I was getting this message until I changed the proxy
> setting and added another 
> line (ScriptAlias /cgi-bin/
> /home/user-name/public_html/cgi-bin/) in my backend 
> server configuration file.

Then your configuration on the backend is wrong. Do you have symlinks or 
something that redirects /home/user-name/public_html/cgi-bin/ to 
/usr/local/httpd_perl/cgi-bin/.

The simplest way to debug the backend is to access it directly first i.e. 
yourbackendserver:8000/perl/... make it working and only then move on to 
the front end config.

p.s. please truncate the parts you don't reply to. No point leaving long 
useless tails.

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message