perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin JN Breame <co...@breame.com>
Subject Re: index.pl weirdness
Date Tue, 13 Jul 2004 16:11:58 GMT
Geoffrey Young wrote:

>Colin JN Breame wrote:
>  
>
>>Hi,
>>
>>I have a problem with apache and mod_perl;
>>
>>The cgi-bin directory has many perl files in it.  All execute except
>>index.pl which produces the browser Save As dialog.  The content of the
>>file saved is the content of index.pl (not something else).
>>
>>However, if I rename the file to something other than index.pl (e.g.
>>index1.pl), it executes as it should.
>>    
>>
>
>this definitely sounds like a mod_autoindex issue
>
>  
>
>>I've removed any DirectoryIndex directives.
>>    
>>
>
>try
>
>  Options +ExecCGI -Indexes
>
>or just
>
>  Options ExecCGI
>
>don't forget to restart apache so the configuration changes are applied :)
>
>if that doesn't work, I'm out of ideas, save issuing a direct telnet request
>to your server to see what is actually coming off the wire.  something like
>this should do the trick:
>
>$ telnet server.example.com 80
>Trying 127.0.0.1...
>Connected to server.example.com (127.0.0.1).
>Escape character is '^]'.
>GET /index.pl HTTP/1.1
>Host: server.example.com
>
>the last two lines are the ones you type, followed by two newlines.
>
>HTH
>
>--Geoff
>
>
>
>  
>
Geoff,

Thanks for your response.

I've checked the Indexes option (Options +ExecCGI -Indexes) but it seems 
to have no effect.

I've also removed all reference to mod_autoindex and again, the problem 
persists.

Colin

-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message